Daily Archiv: Saturday - 23 February 2013

Terjadi error “Unit XXX was compiled with a different version of YYY”, bagaimana solusinya?

Pada saat mengompile contoh project Indy tiba-tiba kita mendapatkan pesan error seperti gambar diatas, bagaimana cara mengatasinya?

Hal tersebut terjadi karena unit yang dibutuhkan project tersebut ada namun dicompile dengan menggunakan versi yang berbeda.

Pada contoh diatas terjadi karena unit SockApp.dcu dicompile bergantung pada unit IdTCPServer.dcu punya Indy9,  sedangkan path IdTCPServer.dcu yang terdaftar di library delphi adalah Indy10 (ada 2 versi Indy yang terinstall).

Solusi pertama adalah merubah alamat Indy yang digunakan pada path Library.

Namun bila kita tidak ingin merubahnya dan ingin tetap menjadikan Indy10 sebagai default (versi lebih baru, lebih banyak fitur), solusinya adalah dengan menambahkan search path khusus project tersebut.

Caranya masuk menu Project-Option dan masukkan alamat Indy9 seperti pada gambar berikut.

Solusi ini bukan hanya untuk indy namun juga untuk unit/komponen lain yang kebetulan mempunyai nama yang sama namun beda versi.

 

Semoga bermanfaat.